
Tips for Creating 
Accessible Excel 
Spreadsheets and 
Tables

1   |   Accessible Communications   |   Accessible Excel and Tables



Add a Unique and 
Descriptive Title to 
your worksheet

Title should be all one-word and use the Pascal Case 
naming convention

Example: RickHansenFoundation instead of 
Rickhansenfoundation

Avoid naming the sheet with a string of numbers and 
letters like 39A8674PtF9-E.

Use Excel's styles to create headings
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Use Accessible Font 
Formats and Colours

Choose sans serif fonts like Arial and Calibri.

Aim for a larger font size such as 14 points.

Do not align text to the center.

Avoid using font attributes like Italics or All capital letters
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Colour contrast
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There must be 
sufficient contrast 
between text and 

background.

Ensure a 4.5:1 
contrast ratio.

Example of good contrast

Black text on White has 
21:1 contrast ratio 

Example of bad contrast

Light grey text on White has 
1.3:1 contrast ratio 

Check contrast with tools like ContrastChecker.com

https://contrastchecker.com/


Add a Summary 
to Cell A1
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The A1 cell is the first cell 
read by screen readers.

Use it to describe the 
worksheet or workbook:

• Explain the structure.

• Mention any tables, 
graphs, or irregular items.

• Identify the starting cell for 
important items.



Add White Space 
Around the Text
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• Increase column width 
and row height to create 
space around the text

• Helps people with low 
vision to read easily.

• Do not create whitespace 
by leaving empty columns 
or rows between text



Important so that the 
screen reader can 
pronounce the text 
correctly.

Unlike Word, you can only 
define the language for 
the entire spreadsheet.

Defining the language 
also affects details like 
currency, dates, etc.

Define the Language 
of the Workbook

7   |   Accessible Communications   |   Accessible Excel and Tables

You can 
change the 
Language by 
selecting:
File > 
Options > 
Language.



Ensure Hyperlinks 
are Informative
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Hyperlinks should clearly describe 
their destination or purpose. This 
helps users who navigate using links 
with assistive technologies.

Do not use URLs as screen readers 
do not read them properly.

Check out our Website to learn more.

Go to https://www.rickhansen.com/ to learn more✘



Hide Unused Rows, 
Columns and Cells
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Hiding unused Rows,  Columns and cells helps:

Hide the extra or irrelevant content from people 
who use Assistive technology

Reduce visual clutter

Minimize possible distractions for people with 
learning disabilities

Right-click on 
any column to 
Hide or Unhide.



Add Alt-Text to 
Images
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Provide Alt-Text descriptions for informative images

Provide a long description for complex images like 
Charts and Shapes

Don't describe decorative images



Create Accessible 
Tables
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Avoid using fixed-width tables

Avoid creating table using the tab key

Do not rely on borders to show a table

Use a simple table structure with columns 
headers

For complex tables, break them up into 
multiple simpler tables.
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Always include headers for rows and 
columns.

Keep data separate, for example: ‘Book 
title’ in one column, ‘Author’ in another.

For complex tables, break them up into 
multiple simpler tables.

✘

Use a simple table structure Do not

Merge cells

Split cells

Nest tables

Mark empty cells with “N/A” or "/"



Email us at Info@RickHansen.com

Questions?
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How to write a descriptive title in spreadsheet 
programs 
A descriptive title helps users understand the purpose of your spreadsheet and 
improves accessibility by making the file easier to identify. 

In Microsoft Excel: 

After saving the spreadsheet and creating a file name, you can add a title to the 
spreadsheet’s properties. 

• In Windows: Select “File” > “Info” > “Add Title.” 
• On a Mac: Select “File” > “Properties” > “Summary” > add a “Title.” 

In Google Sheets: 

• Add a workbook title in the top-left textbox. To rename the workbook, click the 
textbox again or select “File” > “Rename.” 

In Apple Numbers: 

• Save the workbook and input the file name. You can rename your spreadsheet 
by selecting “File” > “Rename.” 
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Colour contrast 
To ensure readability, the text in your worksheet must have sufficient contrast against 
its background. This is especially important for users with low vision. 

How to find the hex code of your colours: 

In Microsoft Excel: 

• Click on the font dropdown menu and select “More Colours.” 
• In Windows, click the “Custom” tab. 
• On Mac, click “Colour Sliders” and select “RGB Sliders” from the dropdown 

menu. 

In Google Sheets: 

• Click on a colour toolbar icon (e.g., font colour) and select the “Custom” option to 
view the hex code. 

In Apple Numbers: 

• Click the colour wheel labelled “Click to show more colours or create your own.” 
• Select “Colour Sliders” and choose “RGB Sliders” from the dropdown menu. The 

hex code appears at the bottom of the popup. 
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How to give worksheets a unique title 
Giving each worksheet a unique title helps users navigate your workbook more easily, 
especially when using assistive technologies. 

In Microsoft Excel: 

• Right-click on the worksheet title you want to change > select “Rename” > type 
the new title > press Enter. 

In Google Sheets: 

• Right-click or click the arrow beside the worksheet title > select “Rename” > type 
the new title > press Enter. 

In Apple Numbers: 

• Right-click or click the arrow beside the worksheet title > select “Rename” > type 
the new title > press Enter. 
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How to delete blank worksheets 
Removing unused worksheets helps streamline your document and reduces confusion. 

In Microsoft Excel: 

• Right-click on the worksheet > select “Delete.” 

In Google Sheets: 

• Right-click on the worksheet > select “Delete” > click “Okay” in the confirmation 
popup. 

In Apple Numbers: 

• Click on the worksheet > open the dropdown menu > select “Delete.” 
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Add a summary of the worksheet/workbook to 
the A1 cell 
Adding a summary in cell A1 provides context for screen reader users and helps them 
understand the structure and contents of the worksheet. 

Include: 

• A description of the workbook or worksheet’s structure, especially if there’s more 
than one table. 

• Any accessibility techniques used. 
• Notes on tables, graphs, and irregular items. 
• The starting cell for the items mentioned in the summary. 

Note: This is not possible in Apple Numbers, as the first row is reserved for headers. 

  

https://www.rickhansen.com/
mailto:info@RickHansen.com


 
 
 

 

300 – 3820 rue Cessna Drive, Richmond, BC/C.-B. Canada V7B 0A2  |  w RickHansen.com  |  e/c info@RickHansen.com  |  t 1 800 213 2131 

              @RickHansenFdn 

Charitable Registration Number / Numéro d'enregistrement d'organisme de bienfaisance : 10765 9427 RR 0001 

 

 

How to increase the column and row width in 
your worksheets 
Adjusting column and row sizes improves readability and ensures that content is not cut 
off or cramped. The ideal width and height depend on your content. 

In Microsoft Excel: 

• Column width: Select the column by clicking its label (e.g., A, B, C…) > right-click 
> choose “Column Width…” > increase the number > click “Okay.” 

• Row height: Select the whole sheet (Ctrl + A or Command + A) or click the top-
left triangle > right-click > select “Row Height…” > increase the number > click 
“Okay.” 

In Google Sheets: 

• Column width: Select the columns > right-click > “Resize columns X–X” > enter a 
new width or choose “Fit to data” > click “Okay.” 

• Row height: Select the rows > right-click > “Resize rows #-#” > enter a new 
height or choose “Fit to data” > click “Okay.” 

You can resize multiple rows or columns at once, but they will all be set to the same 
size unless you use “Fit to data.” 

In Apple Numbers: 

• Column width: Select the column(s) > in the right “Table” toolbar, increase the 
“Width” using the up arrow, change the point value, or click “Fit.” 

• Row height: Select the row(s) > in the right “Table” toolbar, increase the “Height” 
using the up arrow, change the point value, or click “Fit.” 

To resize all rows or columns, deselect everything and adjust the height/width in the 
“Table” toolbar. 
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How to define the language in workbooks 
Defining the language ensures screen readers pronounce content correctly, especially 
in multilingual documents. 

In Microsoft Excel: 

• Click “Tools” > “Language” > select the language > click “Okay.” 

In Google Sheets: 

• Click “File” > “Settings” > select the language for the spreadsheet. 

In Apple Numbers: 

• Click “File” > “Advanced” > “Language & Region” > choose a language > click 
“Okay.” 
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How to create accessible hyperlinks in your 
worksheet 
Hyperlinks should be descriptive and clearly indicate their destination. Avoid vague 
phrases like “Click here.” 

In Microsoft Excel: 

• Click the cell > press Ctrl + K (Windows) or Command + K (Mac) > add the URL 
in the popup. 

In Google Sheets: 

• Click the cell or highlight the text > press Ctrl + K (Windows) or Command + K 
(Mac) > add the URL. 

• To link to a table or another sheet from the A1 summary: highlight the text > 
press Ctrl + K or Command + K > select “Sheets and named ranges” > choose 
the sheet or range (e.g., A2:E16). 

In Apple Numbers: 

• Highlight the text > press Command + K > choose a “Link to” option (webpage, 
email, phone number, or sheet) > add the URL. 
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How to link to different cells in your worksheet 
Linking to specific cells helps users jump directly to relevant data. 

In Microsoft Excel: 

• Click the cell > press Ctrl + K or Command + K > in the popup, select “This 
Document” > enter a cell (e.g., A2) or worksheet name. 

In Google Sheets: 

• Click the cell or highlight the text > select “Sheets and Named Ranges” > choose 
another worksheet or cell range. 

In Apple Numbers: 

• Highlight the text > select “Sheet” in the “Link to” dropdown > choose the 
worksheet > press “Okay.” 
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How to create basic accessible tables 
Tables should be clearly defined with header rows to help screen readers interpret the 
data. 

In Microsoft Excel: 

• Select the table cells > “Insert” > “Table” (or Ctrl + C). 
• Select “My table has headers” to enable the header row. 
• If you didn’t select that option initially, manually check “Header Row” under the 

“Table” toolbar. 

In Google Sheets: 

• Select the table cells > “Format” > “Alternating Colours” > ensure “Header” is 
selected. 

• To add filters: select the headings > “Data” > “Create filters.” 

In Apple Numbers: 

• Tables are created automatically. 
• Under “Format” > “Table,” define header rows/columns. 
• You can also adjust font size, gridlines, and alternate colours. 
• If not preformatted: right-click the row/column label > choose “Convert to Header 

Row/Column.” 
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How to add alt text/long descriptions to your 
graphs and charts 
Long descriptions help users understand complex visuals. These can be added in 
surrounding text or a separate sheet (not in the A1 summary). 

In Microsoft Excel: 

• Select the chart > right-click > “View Alt Text” > edit the auto-generated 
description. 

In Google Sheets: 

• Click the three-dot menu in the chart pane > “Alt text” > add your description. 

How to freeze the heading columns and/or rows 
Freezing headers keeps them visible while scrolling, which is helpful for users with low 
vision. 

In Microsoft Excel: 

• Select the cell below and to the right of the headers > “View” > “Freeze Panes.” 

In Google Sheets: 

• To freeze rows: select the row > right-click > “View more row actions” > “Freeze 
up to row #.” 

• To freeze columns: select the column > right-click > “View more column actions” 
> “Freeze up to column X.” 

In Apple Numbers: 

• To freeze rows: select the row > right-click or use the green arrow > “Freeze 
Header Rows.” 

• To freeze columns: select the column > right-click or use the green arrow > 
“Freeze Header Columns.” 
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How to hide unused rows and columns 
Hiding unused areas reduces clutter and improves navigation for screen reader users. 

In Microsoft Excel: 

• To hide columns: select the column next to your content > Shift + Ctrl + Right 
Arrow > right-click > “Hide.” 

• To hide rows: select the row below your content > Shift + Ctrl + Down Arrow > 
right-click > “Hide.” 

• To unhide: click the top-left corner > right-click > “Unhide.” 

In Google Sheets: 

• To hide columns: select the column next to your content > Shift + Ctrl + Right 
Arrow > right-click > “Hide Columns X–X.” 

• To hide rows: select the row below your content > Shift + Ctrl + Down Arrow > 
right-click > “Hide Rows #-#.” 

• To unhide: click the small arrows on the last visible row/column. 

In Apple Numbers: 

• To hide columns: select the column next to your content > Shift + Control + Right 
Arrow > right-click > “Hide Selected Columns.” 

• To hide rows: select the row below your content > Shift + Control + Down Arrow 
> right-click > “Hide Selected Rows.” 

• To unhide columns: select a column > right-click or use the arrow > “Unhide all 
Columns” or “Unhide columns X–X.”  

• To unhide rows: select a row > right-click or use the arrow > “Unhide all Rows” or 
“Unhide rows #-#.” 
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How to add alt text to images 
Alt text allows screen readers to describe images. Mark decorative images so they’re 
ignored by assistive tech. 

In Microsoft Excel: 

• Right-click the image > “Edit Alt-text” or select the image > “Format” > “Alt-text.” 
• A popup appears on the right to enter your description. 

In Google Sheets: 

• If the image is in a cell: right-click > “Image” > “Add alt text to cell.” 
• A popup appears on the right to enter your description. 

In Apple Numbers: 

• Click the image > “Format” > “Image” tab > add alt text in the “Description” 
textbox. 

How to use the Accessibility Checker in Excel 
Excel’s Accessibility Checker helps identify and fix issues in your spreadsheet. 

• Click the “Accessibility” tab > “Check Accessibility.” 
• Or click the “Accessibility” status at the bottom-left (e.g., “Accessibility: Good to 

go”). 
• A popup appears on the right with inspection results. Click on issues to locate 

and fix them. 

Important: The checker is a helpful starting point but may not catch every issue. 
Manual review is still essential. 
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